#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^a-zA-Z',.?!\s]"
Local $sString = "i'm so happy that you're here with me! :)"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)