package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a-zA-Z',.?!\s]`)
var str = `i'm so happy that you're here with me! :)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}