import Foundation
let pattern = #"[^a-zA-Z',.?!\s]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"i'm so happy that you're here with me! :)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)