using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z',.?!\s]";
string substitution = @"";
string input = @"i'm so happy that you're here with me! :)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}