const regex = /[^a-zA-Z',.?!\s]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z\',.?!\\s]', 'g')
const str = `i'm so happy that you're here with me! :)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);