use strict;
my $str = 'i\'m so happy that you\'re here with me! :)';
my $regex = qr/[^a-zA-Z',.?!\s]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";