re = /[^a-zA-Z',.?!\s]/
str = 'i\'m so happy that you\'re here with me! :)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result