using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+)\s+(.*?)\s*$";
string substitution = @"'$1','$2'";
string input = @"ACMH ADMIT TO XXX
ACSU ADMIT TO XXX SUB-ACUTE (TCU)
ADOPT ADOPTION
AMA AGAINST MEDICAL ADVICE
APSY ADMIT TO CMH PSYCHIATRIC UNIT
CANCEL CANCELLED SERVICE
CANCELER CANCELLED ER
CANCELTRI CANCELLED TRIAGE
EXP EXPIRED ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}