use strict;
my $str = 'ACMH ADMIT TO XXX
ACSU ADMIT TO XXX SUB-ACUTE (TCU)
ADOPT ADOPTION
AMA AGAINST MEDICAL ADVICE
APSY ADMIT TO CMH PSYCHIATRIC UNIT
CANCEL CANCELLED SERVICE
CANCELER CANCELLED ER
CANCELTRI CANCELLED TRIAGE
EXP EXPIRED ';
my $regex = qr/^(\S+)\s+(.*?)\s*$/mp;
my $subst = '\'$1\',\'$2\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";