import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+)\\s+(.*?)\\s*$";
final String string = "ACMH ADMIT TO XXX \n"
+ "ACSU ADMIT TO XXX SUB-ACUTE (TCU) \n"
+ "ADOPT ADOPTION \n"
+ "AMA AGAINST MEDICAL ADVICE \n"
+ "APSY ADMIT TO CMH PSYCHIATRIC UNIT \n"
+ "CANCEL CANCELLED SERVICE \n"
+ "CANCELER CANCELLED ER \n"
+ "CANCELTRI CANCELLED TRIAGE \n"
+ "EXP EXPIRED ";
final String subst = "'$1','$2'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}