re = /^(\S+)\s+(.*?)\s*$/m
str = 'ACMH ADMIT TO XXX
ACSU ADMIT TO XXX SUB-ACUTE (TCU)
ADOPT ADOPTION
AMA AGAINST MEDICAL ADVICE
APSY ADMIT TO CMH PSYCHIATRIC UNIT
CANCEL CANCELLED SERVICE
CANCELER CANCELLED ER
CANCELTRI CANCELLED TRIAGE
EXP EXPIRED '
subst = '\'$1\',\'$2\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result