const regex = /^(\S+)\s+(.*?)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+)\\s+(.*?)\\s*$', 'gm')
const str = `ACMH ADMIT TO XXX
ACSU ADMIT TO XXX SUB-ACUTE (TCU)
ADOPT ADOPTION
AMA AGAINST MEDICAL ADVICE
APSY ADMIT TO CMH PSYCHIATRIC UNIT
CANCEL CANCELLED SERVICE
CANCELER CANCELLED ER
CANCELTRI CANCELLED TRIAGE
EXP EXPIRED `;
const subst = `'$1','$2'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);