# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\S+)\s+(.*?)\s*$"
test_str = ("ACMH ADMIT TO XXX \n"
"ACSU ADMIT TO XXX SUB-ACUTE (TCU) \n"
"ADOPT ADOPTION \n"
"AMA AGAINST MEDICAL ADVICE \n"
"APSY ADMIT TO CMH PSYCHIATRIC UNIT \n"
"CANCEL CANCELLED SERVICE \n"
"CANCELER CANCELLED ER \n"
"CANCELTRI CANCELLED TRIAGE \n"
"EXP EXPIRED ")
subst = "'$1','$2'"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.