#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im),(?=(?:[^"]*""?[^"]*")*[^"]*$)"
Local $sString = ""This is a string", "and this is another with a , in it", Thisisalsovalid, "",,,"And a string""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)