$re = '/,(?=(?:[^"]*""?[^"]*")*[^"]*$)/im';
$str = '"This is a string", "and this is another with a , in it", Thisisalsovalid, "",,,"And a string"';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;