import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?=(?:[^\"]*\"\"?[^\"]*\")*[^\"]*$)";
final String string = "\"This is a string\", \"and this is another with a , in it\", Thisisalsovalid, \"\",,,\"And a string\"";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}