const regex = new RegExp(',(?=(?:[^"]*""?[^"]*")*[^"]*$)', 'gim')
const str = `"This is a string", "and this is another with a , in it", Thisisalsovalid, "",,,"And a string"`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);