#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a\s+href="\.\/view\/(\d{7})\/">"
Local $sString = "<a href="./view/3049532/">" & @CRLF & _
"<a href="./view/398562/">" & @CRLF & _
"<a href="./view/3652872/">" & @CRLF & _
"<a href="./view/3785471/">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")