package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a\s+href="\.\/view\/(\d{7})\/">`)
var str = `<a href="./view/3049532/">
<a href="./view/398562/">
<a href="./view/3652872/">
<a href="./view/3785471/">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}