const regex = /<a\s+href="\.\/view\/(\d{7})\/">/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\s+href="\\.\\\/view\\\/(\\d{7})\\\/">', 'g')
const str = `<a href="./view/3049532/">
<a href="./view/398562/">
<a href="./view/3652872/">
<a href="./view/3785471/">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}