using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s+href=""\.\/view\/(\d{7})\/"">";
string input = @"<a href=""./view/3049532/"">
<a href=""./view/398562/"">
<a href=""./view/3652872/"">
<a href=""./view/3785471/"">
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}