$re = '/<a\s+href="\.\/view\/(\d{7})\/">/';
$str = '<a href="./view/3049532/">
<a href="./view/398562/">
<a href="./view/3652872/">
<a href="./view/3785471/">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);