// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a\s+href="\.\/view\/(\d{7})\/">"#).unwrap();
let string = "<a href=\"./view/3049532/\">
<a href=\"./view/398562/\">
<a href=\"./view/3652872/\">
<a href=\"./view/3785471/\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}