#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^02[0-9]{2}[-][0-9]{7}$"
Local $sString = "0212-1234567"
Local $sSubst = "^[04](1|2)(2|4|6)$"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)