re = /^02[0-9]{2}[-][0-9]{7}$/
str = '0212-1234567'
subst = '^[04](1|2)(2|4|6)$'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result