use strict;
my $str = '0212-1234567';
my $regex = qr/^02[0-9]{2}[-][0-9]{7}$/p;
my $subst = '^[04](1|2)(2|4|6)$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";