package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^02[0-9]{2}[-][0-9]{7}$`)
var str = `0212-1234567`
var substitution = "^[04](1|2)(2|4|6)$"
fmt.Println(re.ReplaceAllString(str, substitution))
}