const regex = /^02[0-9]{2}[-][0-9]{7}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^02[0-9]{2}[-][0-9]{7}$', 'g')
const str = `0212-1234567`;
const subst = `^[04](1|2)(2|4|6)$`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);