using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\@(?P<key>[a-zA-Z0-9]+)\s{1,}(?P<value>.*)";
string input = @"/**
@author Marian Gabriel
@route /page/contact
@name Contact Plugin
@version 0.1beta
@company VMG
@type Page
**/
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}