import re
regex = re.compile(r"\@(?P<key>[a-zA-Z0-9]+)\s{1,}(?P<value>.*)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("/**\n"
"@author Marian Gabriel\n"
"@route /page/contact\n"
"@name Contact Plugin\n"
"@version 0.1beta\n"
"@company VMG\n"
"@type Page\n"
"**/\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")