const regex = /\@(?P<key>[a-zA-Z0-9]+)\s{1,}(?P<value>.*)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\@(?P<key>[a-zA-Z0-9]+)\\s{1,}(?P<value>.*)', 'gim')
const str = `/**
@author Marian Gabriel
@route /page/contact
@name Contact Plugin
@version 0.1beta
@company VMG
@type Page
**/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}