re = /\@(?P<key>[a-zA-Z0-9]+)\s{1,}(?P<value>.*)/im
str = '/**
@author Marian Gabriel
@route /page/contact
@name Contact Plugin
@version 0.1beta
@company VMG
@type Page
**/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end