$re = '/\@(?P<key>[a-zA-Z0-9]+)\s{1,}(?P<value>.*)/im';
$str = '/**
@author Marian Gabriel
@route /page/contact
@name Contact Plugin
@version 0.1beta
@company VMG
@type Page
**/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);