package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\@(?P<key>[a-zA-Z0-9]+)\s{1,}(?P<value>.*)`)
var str = `/**
@author Marian Gabriel
@route /page/contact
@name Contact Plugin
@version 0.1beta
@company VMG
@type Page
**/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}