#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/(?:.*?\.)?domain\.com.*"
Local $sString = "https://domain.com" & @CRLF & _
"https://domain.com/test/123.pdf" & @CRLF & _
"https://www.domain.com" & @CRLF & _
"https://testabc.domain.com" & @CRLF & _
"https://test.abc.domain.com" & @CRLF & _
"http://domain.com" & @CRLF & _
"https://www.domaaaain.com" & @CRLF & _
"https://www.domaaaain.com/test/abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")