// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/(?:.*?\.)?domain\.com.*").unwrap();
let string = "https://domain.com
https://domain.com/test/123.pdf
https://www.domain.com
https://testabc.domain.com
https://test.abc.domain.com
http://domain.com
https://www.domaaaain.com
https://www.domaaaain.com/test/abc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}