use strict;
my $str = 'https://domain.com
https://domain.com/test/123.pdf
https://www.domain.com
https://testabc.domain.com
https://test.abc.domain.com
http://domain.com
https://www.domaaaain.com
https://www.domaaaain.com/test/abc';
my $regex = qr/https:\/\/(?:.*?\.)?domain\.com.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}