import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/(?:.*?\\.)?domain\\.com.*";
final String string = "https://domain.com\n"
+ "https://domain.com/test/123.pdf\n"
+ "https://www.domain.com\n"
+ "https://testabc.domain.com\n"
+ "https://test.abc.domain.com\n"
+ "http://domain.com\n"
+ "https://www.domaaaain.com\n"
+ "https://www.domaaaain.com/test/abc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}