package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/(?:.*?\.)?domain\.com.*`)
var str = `https://domain.com
https://domain.com/test/123.pdf
https://www.domain.com
https://testabc.domain.com
https://test.abc.domain.com
http://domain.com
https://www.domaaaain.com
https://www.domaaaain.com/test/abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}