import re
regex = re.compile(r"https:\/\/(?:.*?\.)?domain\.com.*", flags=re.MULTILINE)
test_str = ("https://domain.com\n"
"https://domain.com/test/123.pdf\n"
"https://www.domain.com\n"
"https://testabc.domain.com\n"
"https://test.abc.domain.com\n"
"http://domain.com\n"
"https://www.domaaaain.com\n"
"https://www.domaaaain.com/test/abc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")