using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/(?:.*?\.)?domain\.com.*";
string input = @"https://domain.com
https://domain.com/test/123.pdf
https://www.domain.com
https://testabc.domain.com
https://test.abc.domain.com
http://domain.com
https://www.domaaaain.com
https://www.domaaaain.com/test/abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}