#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(<span\s*([a-z\-]+=\"[A-Za-z\-\s\:\.]+\"\s*)+data-placeholder=\"(?<property>[a-zA-Z\.]+)\"\s+data-data-source=\"(?<dataSource>[a-zA-Z:]+)\">\s?[<>a-z\"\s\/\-\=\.A-Z]+\s*<\/span>))+"
Local $sString = "<p>Probiere <span contenteditable="false" class="fr-deletable fr-tribute" data-placeholder="profile.company" data-data-source="DataSource:Owner"> <i class="fas fa-database"></i> Firma.Firma</span> aus <span contenteditable="false" class="fr-deletable fr-tribute" data-placeholder="profile.firstName" data-data-source="DataSource:Target"> <i class="fas fa-database"></i> Kunde.Vorname</span> </p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")