using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(<span\s*([a-z\-]+=\""[A-Za-z\-\s\:\.]+\""\s*)+data-placeholder=\""(?<property>[a-zA-Z\.]+)\""\s+data-data-source=\""(?<dataSource>[a-zA-Z:]+)\"">\s?[<>a-z\""\s\/\-\=\.A-Z]+\s*<\/span>))+";
string input = @"<p>Probiere <span contenteditable=""false"" class=""fr-deletable fr-tribute"" data-placeholder=""profile.company"" data-data-source=""DataSource:Owner""> <i class=""fas fa-database""></i> Firma.Firma</span> aus <span contenteditable=""false"" class=""fr-deletable fr-tribute"" data-placeholder=""profile.firstName"" data-data-source=""DataSource:Target""> <i class=""fas fa-database""></i> Kunde.Vorname</span> </p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}