$re = '/(?:(<span\s*([a-z\-]+=\"[A-Za-z\-\s\:\.]+\"\s*)+data-placeholder=\"(?<property>[a-zA-Z\.]+)\"\s+data-data-source=\"(?<dataSource>[a-zA-Z:]+)\">\s?[<>a-z\"\s\/\-\=\.A-Z]+\s*<\/span>))+/m';
$str = '<p>Probiere <span contenteditable="false" class="fr-deletable fr-tribute" data-placeholder="profile.company" data-data-source="DataSource:Owner"> <i class="fas fa-database"></i> Firma.Firma</span> aus <span contenteditable="false" class="fr-deletable fr-tribute" data-placeholder="profile.firstName" data-data-source="DataSource:Target"> <i class="fas fa-database"></i> Kunde.Vorname</span> </p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);