import re
regex = re.compile(r"(?:(<span\s*([a-z\-]+=\"[A-Za-z\-\s\:\.]+\"\s*)+data-placeholder=\"(?<property>[a-zA-Z\.]+)\"\s+data-data-source=\"(?<dataSource>[a-zA-Z:]+)\">\s?[<>a-z\"\s\/\-\=\.A-Z]+\s*<\/span>))+", flags=re.MULTILINE)
test_str = "<p>Probiere <span contenteditable=\"false\" class=\"fr-deletable fr-tribute\" data-placeholder=\"profile.company\" data-data-source=\"DataSource:Owner\"> <i class=\"fas fa-database\"></i> Firma.Firma</span> aus <span contenteditable=\"false\" class=\"fr-deletable fr-tribute\" data-placeholder=\"profile.firstName\" data-data-source=\"DataSource:Target\"> <i class=\"fas fa-database\"></i> Kunde.Vorname</span> </p>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")