import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(<span\\s*([a-z\\-]+=\\\"[A-Za-z\\-\\s\\:\\.]+\\\"\\s*)+data-placeholder=\\\"(?<property>[a-zA-Z\\.]+)\\\"\\s+data-data-source=\\\"(?<dataSource>[a-zA-Z:]+)\\\">\\s?[<>a-z\\\"\\s\\/\\-\\=\\.A-Z]+\\s*<\\/span>))+";
final String string = "<p>Probiere <span contenteditable=\"false\" class=\"fr-deletable fr-tribute\" data-placeholder=\"profile.company\" data-data-source=\"DataSource:Owner\"> <i class=\"fas fa-database\"></i> Firma.Firma</span> aus <span contenteditable=\"false\" class=\"fr-deletable fr-tribute\" data-placeholder=\"profile.firstName\" data-data-source=\"DataSource:Target\"> <i class=\"fas fa-database\"></i> Kunde.Vorname</span> </p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}