use strict;
my $str = '<p>Probiere <span contenteditable="false" class="fr-deletable fr-tribute" data-placeholder="profile.company" data-data-source="DataSource:Owner"> <i class="fas fa-database"></i> Firma.Firma</span> aus <span contenteditable="false" class="fr-deletable fr-tribute" data-placeholder="profile.firstName" data-data-source="DataSource:Target"> <i class="fas fa-database"></i> Kunde.Vorname</span> </p>';
my $regex = qr/(?:(<span\s*([a-z\-]+=\"[A-Za-z\-\s\:\.]+\"\s*)+data-placeholder=\"(?<property>[a-zA-Z\.]+)\"\s+data-data-source=\"(?<dataSource>[a-zA-Z:]+)\">\s?[<>a-z\"\s\/\-\=\.A-Z]+\s*<\/span>))+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}