// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:(<span\s*([a-z\-]+=\"[A-Za-z\-\s\:\.]+\"\s*)+data-placeholder=\"(?<property>[a-zA-Z\.]+)\"\s+data-data-source=\"(?<dataSource>[a-zA-Z:]+)\">\s?[<>a-z\"\s\/\-\=\.A-Z]+\s*<\/span>))+"#).unwrap();
let string = "<p>Probiere <span contenteditable=\"false\" class=\"fr-deletable fr-tribute\" data-placeholder=\"profile.company\" data-data-source=\"DataSource:Owner\"> <i class=\"fas fa-database\"></i> Firma.Firma</span> aus <span contenteditable=\"false\" class=\"fr-deletable fr-tribute\" data-placeholder=\"profile.firstName\" data-data-source=\"DataSource:Target\"> <i class=\"fas fa-database\"></i> Kunde.Vorname</span> </p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}