const regex = /(?:(<span\s*([a-z\-]+=\"[A-Za-z\-\s\:\.]+\"\s*)+data-placeholder=\"(?<property>[a-zA-Z\.]+)\"\s+data-data-source=\"(?<dataSource>[a-zA-Z:]+)\">\s?[<>a-z\"\s\/\-\=\.A-Z]+\s*<\/span>))+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(<span\\s*([a-z\\-]+=\\"[A-Za-z\\-\\s\\:\\.]+\\"\\s*)+data-placeholder=\\"(?<property>[a-zA-Z\\.]+)\\"\\s+data-data-source=\\"(?<dataSource>[a-zA-Z:]+)\\">\\s?[<>a-z\\"\\s\\\/\\-\\=\\.A-Z]+\\s*<\\\/span>))+', 'gm')
const str = `<p>Probiere <span contenteditable="false" class="fr-deletable fr-tribute" data-placeholder="profile.company" data-data-source="DataSource:Owner"> <i class="fas fa-database"></i> Firma.Firma</span> aus <span contenteditable="false" class="fr-deletable fr-tribute" data-placeholder="profile.firstName" data-data-source="DataSource:Target"> <i class="fas fa-database"></i> Kunde.Vorname</span> </p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}