#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((.*?) *\((\d+)\))(?: *\{((.*?) *\((.+?)\)) *\})?"
Local $sString = ""!?Text" (1234)" & @CRLF & _
""#1 Text" (1234)" & @CRLF & _
"#2 Text (1234) {Some text (#1.1)}" & @CRLF & _
"Text (1234)" & @CRLF & _
"Some Other Text: More Text here 1234-4321 (1234) (V)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")